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Preface

This System Administrator Guide shows you how to:
* Install the SmarTerm Administrator Toolbox, which you use to create and maintain profiles for users.
* Configure SmarTerm for your users, including the creation of profile servers and profiles.

This guide, in combination with the detailed online help system and with the online manuals, provides
what you need to install the SmarTerm Administrator Toolbox and manage profiles.

How to use this guide

Read the “Introduction” on page 6 for information on the concepts behind profile management.
“Installing SmarTerm with the Administrator Toolbox” on page 10 shows how to set up the
Administrator Toolbox. The “Profile Management Workbook™” on page 14 gives examples of working
through the major tasks of profile management. The “Profile Management Reference” on page 26 contains
a summary of major profile management procedures. Finally, the “Features Reference” on page 31
describes the SmarTerm features you can use when creating and modifying profiles.

Information and technical support

If you encounter problems with SmarTerm, check through the troubleshooting hints in the online help
and SmarTerm documentation. Many situations are common and can be corrected easily with the
suggestions given there. If your problems persist, call Esker’s Technical Support department for assistance.

Before you call for technical support:

* Know your license number. It’s on the Registration card that comes with your product. (If you entered
the number during installation, you can display this license number by selecting Help>About.)

* Be aware that we may need detailed information about the hardware and software on your computer,
so a working knowledge of Windows, the setup of your PC, and the way you are using SmarTerm may
be necessary.

+ Isolate the problem as much as possible. Does the problem occur every time you enter a certain
sequence of keystrokes, or do you have to do something else first? Writing down a short description of
the steps it takes to repeat the problem will help both of us to isolate the problem.

+ Seat yourself at the PC that is giving you trouble and call us from there. We may need to have you run
one or more diagnostic tests, and these must be done on the computer with the problem.



Introduction

SmarTerm addresses the growing reliance on system administration and networks with profile
management tools. SmarTerm is designed to help reduce the overall costs of software configuration and
maintenance by:

* Enabling desktop standardization. SmarTerm lets you, the system administrator, define how users
work with SmarTerm through the use of profiles and profile servers.

* Providing automated support for user problems. Users can restore feature sets from profiles, which
can include SmarTerm’s automation features such as keyboard maps, macros, HotSpots, and Triggers.
Administrators or help desks can restore SmarTerm configurations back to corporate or departmental
standards after users have changed settings on local workstations. (Open mode only.)

Note:

User interface changes made by the system administrator will always be propagated to the users through
profiles. However, no other profile feature is available to users or administrators when operating in
lockdown mode. When operating in open mode, all profile features are available.

Note:

The Administrator Toolbox is intended to help you create, manage, and deploy SmarTerm profiles for
users. This guide assumes that you’re a system administrator who plans to create and deploy profiles for
network users. If your users install SmarTerm on their PCs, and you aren’t responsible for managing these
users on a network, there’s no need for you to install and use the Administrator Toolbox.

How does profile management work?

The SmarTerm Administrator Toolbox and other SmarTerm features let you create and customize
SmarTerm profiles for users. The profiles determine the SmarTerm sessions and features that users can
access.

The Administrator Toolbox is available under the SmarTerm Tools menu. This feature is only available if
the Administrator Toolbox has been installed. Only users who have administrator rights may install the
Administration Toolbox.

See the SmarTerm Getting Started Guide for complete instructions on installing SmarTerm. To install the
Administrator Toolbox, see “Installing SmarTerm with the Administrator Toolbox” on page 10 in this
guide.

With the Administrator Toolbox, you can:

+ Create a profile server.

* Load an existing profile from a profile server.

* Create, modify, and delete profiles on a profile server.

* Configure a profile by defining its SmarTerm user interface appearance. You can enable or disable
SmarTerm menu items, editors, and dialog tabs.
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The Restore and Undo Restore commands on the Tools menu are available to you and your users to
restore a profile and undo a profile restore in open mode.

In addition to the Administrator Toolbox features, you can use the Properties > Global Options tabs to
configure SmarTerm user profiles. These tabs include:

+ Profiles, where you specify a profile server path and profile name

» Session Limits, where you can specify the total number of sessions the user can access at one time and
limit a user to a single connection per host or IP address

+ Other tabs that let you specify options for emulation, user help, shutdown, and startup

About profiles and profile servers

A profile is a collection of SmarTerm feature and session characteristics that control how a user sees and
works with SmarTerm. It is, in essence, a template that includes administrator-defined settings for
sessions, automation tools (such as SmarTerm Buttons, keyboard maps, HotSpots, and SmartMouse), and
the user interface. SmarTerm comes with a factory default profile that makes all tools and features
available. Use the Administrator Toolbox to define your own profile and profiles for users.

A profile server is a folder, usually located on a network server, that stores SmarTerm profiles. Profile
servers contain the profiles you create, as well as the factory default profile that comes with SmarTerm.
You can create a profile server after installing the Administrator Toolbox.

It’s also possible to create multiple profile servers at different locations. However, we recommend that
you keep the profile server structure as simple as possible to reduce possible management and
maintenance issues.

What’s included in a profile?

A profile contains folders that hold configurations for SmarTerm features, tools, and user interfaces (UI)
available to the users of that profile. When you create or modify a profile, you define the configurations
held in the profile folders, which include the following items:

+ Button pictures—graphics for SmarTerm Buttons
» Color schemes—color settings for elements in a SmarTerm window

* Global options—specifications for profile server path and active profile; emulation options; user help;
and session limits, shutdown, and startup

* HotSpots—clickable areas that initiate defined actions within a host session
+ Keyboard maps—customized settings for keyboards for sending words, commands, or macros to a host

* LPD queues configuration—settings for an installed Windows printer that’s made available to profile
users

* Macros—keystroke or typed macro language scripts, either supplied by SmarTerm or defined by users,
that automate functions for a host session

¢ Online manuals—Adobe Acrobat .PDF versions of SmarTerm manuals
* Sessions—host sessions accessible to users of a profile
¢ SmarTerm Buttons—custom buttons that automate functions within a host session

» Triggers—application navigation aids that load SmarTerm tools for a specific host session or screen
within a host session

* Ul configuration—settings that determine how the SmarTerm user interface appears to profile users



Introduction

About profiles and sessions

SmarTerm profiles exist separately and at a higher level than sessions. A profile can include sessions as
part of the profile makeup. This lets you provide session access to users who are assigned a certain
profile. The sessions you create for the current profile will appear in the Sessions folder for that profile.
On the other hand, you don’t have to include a session as part of a profile.

How to configure profiles

When you configure profiles, you also define the access that users will use when accessing SmarTerm
features. You can configure a profile that has all the features of SmarTerm, or you can limit the profile so
that users see only those features you want them to see. When you create and deploy a profile for a group
of users, they will see the SmarTerm sessions, menu items, dialogs, and features that you have defined in
the profile.

For some users, you might want to copy your own administrator profile or let them use the factory default
profile, which has full access to all SmarTerm features. Other users might benefit from a more limited
choice of SmarTerm features. Profiles let you control how SmarTerm works for any range of users. For
details on defining features available in a profile, see “Modifying a profile” on page 18.

Profile security

If you’re creating profiles for multiple groups of users, you should consider how to maintain profile
security for those groups.

Experienced users might require several different profiles for the work that they do with SmarTerm. You
can set up any number of profiles on the same profile server for these users. By selecting Properties >
Global Options and clicking the Profiles tab, these users will be able to select any profile available on
the profile server.

On the other hand, if you want to limit a user group to just one profile, you can disable the Profiles tab
for that particular group. For information about disabling SmarTerm menu items and features, see
Changing the user interface (UI) on page 20.

You can also create multiple profile servers to enforce profile security among network groups. Each group
would see only the profiles on the profile server that you assign to them. See Creating profiles on page
17.

To protect profiles from unapproved changes, we recommend that you write-protect them in the way
that’s best for your server environment.

An overview of what you need to do

Here’s what you do to take full advantage of SmarTerm profile management features, and where you can
find the information:

What you need to do: Where to find the information:

Install SmarTerm on a multi-user Installing SmarTerm with the Administrator Toolbox on page 10
server.

Install the Administrator Toolbox. Installing SmarTerm with the Administrator Toolbox on page 10

Create a profile server. Profile Management Workbook on page 14 and Profile
Management Reference on page 26
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What you need to do: Where to find the information:
Create, modify, and manage Profile Management Workbook on page 14, and Profile
profiles. Management Reference on page 26




Installing SmarTerm with the Administrator
Toolbox

The SmarTerm Administrator Toolbox lets you create and customize SmarTerm profiles for users.

If you plan to use SmarTerm on a single-user basis and are not responsible for managing SmarTerm for
users on a network, there’s no need for you to install and use the Administrator Toolbox. See the Getting
Started guide for instructions on installing a single-user version of SmarTerm.

Before you install

To make the installation process go as smoothly as possible, shut down any programs running in the
background, such as:

* Applications

* Virus protection programs

Running Setup

Note: As you prepare for the Administrator Toolbox Setup, check the online Release Notes (Start >
Programs > SmarTerm > Release Notes) for information about installation.

Also, any user that needs access to the Administrator Toolbox needs to run the administrator setup and
have administration rights.

To install the Administrator Toolbox:

1. Insert the CD into the CD-ROM drive. If the CD-ROM “autorun” feature is disabled or unavailable, run
autorun.exe from the root directory of the CD. You can also run the program from a CD image located on
a server.

2. Choose Install SmarTerm from the CD Browser window. Follow the prompts until you reach the Setup
Type window where you must choose Custom. If you have already installed SmarTerm, you can choose
to modify the existing install and proceed with the following steps.

3. In the Custom Setup window, select the Administrator Toolbox and choose This feature will be installed
on local hard drive.

4. Follow the prompts.

When you launch SmarTerm, the Administrator Toolbox appears under the Tools menu.

Windows Installer Notes

SmarTerm Setup provides a number of pre-defined properties that can be set via the command line using
Windows Installer arguments. For complete documentation on how to use these properties and for other
Windows Installer command line information, go to the MSDN web site (http://msdn.microsoft.com/) and
search for Windows Installer Command Line Options.
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Supported properties
INSTALLDIR

USEPROFILESERVER

PROFILEPATH

PROFILENAME

PIDKEY

ACTIVATIONCODE
LICENSESTRING

ADDFRENCH

ADDSPANISH

ADDGERMAN

ADVANCEDSETUP

Optional. Allows an administrator to specify the SmarTerm
installation folder. If not specified, the following default path is
used:

C:\PROGRAM FILES\ESKER\SMARTERM on a 32-bit OS
C:\PROGRAM FILES (x86)\ESKER\SMARTERM on a 64-bit OS

Optional. Allows an administrator to specify whether to use a
profile server. Acceptable values are “Yes” or “No”. These values
are case sensitive. If this property is set to "Yes" then the
PROFILEPATH and PROFILENAME properties must also be set.
NOT setting this property is the same as setting it to "No".

Required if USEPROFILESERVER s set to "Yes". The path to the
ST profile may be specified with this property. The last character
should not be a \'.

Required if USEPROFILESERVER s set to "Yes". The name of
the ST profile may be specified with this property. The last
character should not be a '\'.

Required. The hyphens are required.
Format: "###4## 44 #H# 44 #HH-HHH-H#4"

Required. Format: "####4#### 44444

Only required if product was purchased as a site license. The
license string can be any string containing both letters and
numbers. Usually the string contains the company name and is
case sensitive.

Optional. Assigning any value to this property will cause French
components to be installed. Omitting this property will cause
French components to not be installed.

Optional. Assigning any value to this property will cause Spanish
components to be installed. Omitting this property will cause
Spanish components to not be installed.

Optional. Assigning any value to this property will cause German
components to be installed. Omitting this property will cause
German components to not be installed.

Optional. If you set this property to "1", the setup wizard displays
additional steps for advanced configuration. With this option, you
can specify from the setup wizard if the users will share a common
file location, and whether to use a profile server.

Typical command line usage

msiexec.exe /i /gn <drive>:\<path>\SmarTerm.msi PROPERTY=Value

11
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When specifying multiple properties, separate them with a single space. Note that it is not necessary to
run SmarTerm.exe using this method. Instead, specify the language-specific .msi to install that specific
language.

Examples

Below are examples of Windows Installer command lines used to install SmarTerm. The command would
use a single line, and is only broken into multiple lines because of space limitations.

Example 1

msiexec /i "F:\SMARTERM IMAGE\SMARTERM.MSI" PIDKEY="012345678901234-567-89"
ACTIVATION CODE="abcdefghijklmn" ADDLOCAL="ALL" /gn+

/i F:\SMARTERM IMAGE\SMARTERM.MSI Location of SmarTerm installation source
PIDKEY/ACTIVATIONCODE User license
ADDLOCAL="ALL" Add all components
/an+ silent install - notify user when installation is
finished
Note:

INSTALLDIR is not specified, so SmarTerm will install to the default program directory:
C:\PROGRAM FILES\ESKER\SMARTERM on a 32-bit OS
C:\PROGRAM FILES (x86)\ESKER\SMARTERM on a 64-bit OS

Example 2

msiexec /i "F:\SMARTERM IMAGE\SMARTERM.MSI" INSTALLDIR="C:\SMARTERM"
PIDKEY="012345678901234-567-89" ACTIVATIONCODE="abcdefghijklmn"
USEPROFILESERVER="Yes PROFILEPATH="F:\SMARTERM PROFILE\PROFILES"
PROFILENAME="FACTORY" ADDFRENCH="Yes" ADDLOCAL="AdminTools" /gb

/i "F:\SMARTERM IMAGE\SMARTERM.MSI" Location of SmarTerm installation source

INSTALLDIR="C:\SMARTERM" Install SmarTerm to the CASMARTERM
directory

PIDKEY/ACTIVATIONCODE User license

USEPROFILESERVER="Yes" Use an existing profile with this installation.

PROFILEPATH="F:\SMARTERM PROFILE\PROFILES" Location of profile server directory

PROFILENAME="FACTORY" Name of profile directory contained in

profile server directory
ADDFRENCH="Yes" Add French language

ADDLOCAL="AdminTools" Install the Administrator Toolbox with
normal install

/qb Basic installation Ul

Example 3

12
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msiexec /i "F:\SMARTERM IMAGE\SMARTERM.MSI" PIDKEY="012345678901234-567-89"
ACTIVATIONCODE="abcdefghijklmn" ADDLOCAL="FTP,LPD" /gr /L*v "F:\SMARTERM
LOG\LOGFILE.TXT"

/i "F:\SMARTERM IMAGE\SMARTERM.MSI" Location of SmarTerm installation source

PIDKEY/ACTIVATIONCODE User License

ALLLOCAL="FTP, LPD" Add only FTP & LPD with normal
installation

/qr Reduced installation UI - advise user at end
of installation

/L*v "F:\SMARTERM LOG\LOGFILE.TXT" Generates a verbose install log file in the

specified location

13



Profile Management Workbook

This chapter shows you how to use the SmarTerm Administrator Toolbox and other profile management
tools.

Note:
For streamlined instructions on working with profiles, without working through examples, see “Profile
Management Reference” on page 26.

The examples in this chapter take you through setting up profiles for three different departments in a
company: Marketing, Accounting, and Sales. Let’s suppose that you want to set up an e-mail session in
SmarTerm for each department, and you want to customize the session for each department. You can
define the session, tools, and features for each department as part of a profile.

This chapter uses examples to show how to:
* Use the Administrator Toolbox toolbar

* Create profile servers

+ Select a profile server and change the profile server path
+ Create your own profile

* Load a profile

 Create user profiles

* Modify a profile with SmarTerm’s tools

* Restore profiles and profile features

* Undo a profile restore

* Merge profiles

* Delete a profile

Note:

To use profiles with SmarTerm for Terminal Services Edition, you need to have a secure server, create a
profile with the capabilities you want your users to have and note profile differences in lockdown versus
open mode.

Using the Administrator Toolbox toolbar

You might prefer to use the Administrator Toolbox toolbar icons, instead of selecting menu items, as you
go through this workbook chapter. To display the Administrator Toolbox toolbar:

1. With SmarTerm open, select View > Toolbars.

2. In the Customize dialog, check Admin Toolbox and click OK.

The Administrator Toolbox toolbar appears.
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Admin Toolbox x|
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You can dock the toolbar in the SmarTerm window or leave it floating.

Creating a profile server

Plan carefully where you want to store user profiles and how you will deploy them to your users. Also
consider whether users should have profiles available to them other than the one you assign when you set
up the Automatic Install Wizard.

Here are some guidelines for specifying the profile server path during the Administrator Toolbox Setup:

+ If you want to let all users have access to all profiles that you create, specify a profile server path that
everyone, including you, will be able to access. To protect these profiles from unauthorized changes,
we recommend that you write-protect them in a way that’s best for your network server type.

* Make sure that intended locations have ample disk space to hold profile folders, especially if you
create many profiles or profile servers. The factory default profile is copied to each profile server you
create. Online manuals alone take up about 12MB of disk space and are copied (as part of the factory
profile) every time a new profile server is created.

* You can specify Universal Naming Convention (UNC) paths for profile server locations.

 If you create a profile server on a network location, you should limit user access to that location during
installation.

To create a new profile server:

1. Use Windows Explorer to create folders in a location that’s accessible for users. Name the folder
<network drive>:\Profiles\Acctserver for this example.

2. Open SmarTerm and select Tools > Administrator Toolbox > Save Profile to Server As.

3. In the Save Profile to Server dialog, specify a profile server path and a profile name. For this path
example, type the network path you created in Windows Explorer: <network
drive>:\Profiles\Acctserver. Type Accounting in the Profile name box.

You can specify UNC paths for profile server locations. Doing so can be beneficial when users are
mapped to a wide variety of drives.

4. Click OK to create the profile server and profile.

5. Because a profile server doesn’t exist on the specified path, SmarTerm asks whether you want to create a
new profile server at this location. Click Yes.

Profile server folders

The SmarTerm factory profile is copied to any new profile server you create and appears there with the
new profile folder. Open Windows Explorer and go to the location where you created the new profile
server in the preceding example. The following folders appear under the Acctserver profiles server folder:

15
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The profile folder itself is named Accounting. The other folders hold values for features contained in the
profile.

Lx

PERORD

The factory profile is copied to the new profile server so restores from the factory default are possible.

Note:
If you intend to create multiple profile servers, be sure to check first that the intended location has ample
disk space.

Selecting a profile server

If you create multiple profile servers, you can select a different profile server than the current one. For
example, if a network-based profile server is active and you want to load your Admin profile from your
PC’s hard drive, you first select the profile server where the Admin profile resides. Use the Properties >
Global Options > Profiles tab to select a profile server.

To select a profile server:

1. Select Properties > Global Options > Profiles tab. The Profile server path box displays the current profile
server path.

2. In the Profile server path box, type or browse for a path to another profile server. For this example,
browse for and select the profile server you created for yourself as a system administrator.

Note:
If you browse for a profile server, be sure to select the profile server folder (“profiles” in the example), not
a profile folder (“Admin” or “Factory”) in the profile server folder.

3. From the Profile name list, select the Admin profile and click OK.
SmarTerm asks you to confirm restoring sessions and tools from the selected profile.
4. Click Yes.

The Restore Status message box appears while SmarTerm restores the settings from the specified Admin
profile.

Even though the Admin profile name appears in the title bar, you must exit and restart SmarTerm to
activate the profile.

16
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Creating profiles

This section uses examples to show how to create your own profile, load a profile from the profile server,
and create a user profile.

Creating your own profile

17

First, you will want to create your own administrator profile with all the capabilities of the factory
default profile that comes with SmarTerm. You can modify the profile by adding sessions and changing
the appearance and availability of SmarTerm tools and features. We recommend, however, that any
administrator profile should retain all of the capabilities that come with the factory profile.

To create your own profile:

. Open SmarTerm.

. Make sure that the factory profile is active. The profile name appears in the title bar, separated by a

hyphen from the product name.

%E SmarTerm - Factory
File %iew Tools Properties Help

If the factory profile isn’t active, do the following in order:

* Select Tools > Administrator Toolbox > New Profile. A message warns that this action will delete
SmarTerm sessions and tools and replace them with factory defaults. The previously active profile will
remain intact on the profile server.

* Click Yes. SmarTerm loads the factory profile and displays a status message. After the factory defaults
are loaded, the changes will not take effect until you exit and restart SmarTerm.

+ Exit and restart SmarTerm for the changes to take effect.

. Select Tools > Administrator Toolbox > Save Profile to Server.

The Save Profile to Server dialog appears:

. In the Profile server path box, the profile server path should be the one you specified during

Administrator Toolbox installation. If you didn’t create a profile server during installation, you can do so
now by following the instructions in “Creating a profile server” on page 15.

. In the Profile name box, type Admin for the new profile name in this example and click OK. The name

can be as long as the Profile name box allows. (You can’t overwrite or delete the factory profile.)

A new profile loads after you save it, and its name appears in the SmarTerm title bar. If a session is open,
the session name appears enclosed within brackets.

This example saves the Admin profile with the same values as the default factory profile, which has all
SmarTerm features available. You can use SmarTerm’s tools and features to change the profile, which is a
typical part of the profile process and is described in “Modifying a profile” on page 18.

Note:
After you create and save a new profile, it remains active until you load a different profile or specify a
different profile server.
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Loading a profile

When you load a profile, its available sessions, features, and user interface replace those of the profile
you had previously loaded. In the following example, the Admin profile that you created is active, and
you’ll load the factory profile.

To load a profile:

1. Select Tools > Administrator Toolbox > Load Profile from Server.

The Load Profile from Server dialog displays the profiles that exist on the current profile server. (If you
have multiple profile servers and want to change the current profile server path, select Properties > Global
Options and click the Profiles tab. See “Creating a user profile” on page 18 for more information.)

2. Select a profile name from the list and click OK. For this example, select the factory profile. SmarTerm
notifies you that this action will replace all SmarTerm sessions and tools.

3. Click Yes to load the profile.

You must exit and restart SmarTerm for the profile to take effect.

Creating a user profile

After creating the Admin profile, you can use it as a model for user profiles. The following example will
create a user profile called Marketing:

1. Make sure that the active profile is the one on which you want to base a new user profile. (If it isn’t,
select Tools > Administrator Toolbox > Load Profile from Server.) In this example, you can use either the
factory or Admin profile as a model for a new user profile.

2. Select Tools > Administrator Toolbox > Save Profile to Server As.

This saves an existing profile as a new profile. For this example, use the same profile server path as the
Admin and factory profiles. If you have multiple profile servers, you can specify another profile server
path: if that path doesn’t exist, SmarTerm can create a new profile server. See “Creating a profile server”
on page 15.

3. In the Profile name field, type a name for the profile, and click OK. For this example, type Marketing.

4. Click OK to create the user profile.

The Marketing profile is active and its name appears in the title bar. Now you can modify it.

Modifying a profile
This section leads you through a few examples of the ways you can use SmarTerm features to change and
enhance the Marketing profile created in the preceding section. After you modify this profile, you can use
it as a template for other profiles saved under different names. You can use all available SmarTerm
features to customize a profile’s appearance, tools, and available sessions.

Note:

For a description of major SmarTerm features, see the “Features Reference” on page 31, or look up a
specific tool in online help by selecting Help > SmarTerm Help and opening the Tools book in the Help
Contents dialog. Sample files that come with SmarTerm contain examples of SmarTerm Buttons,
HotSpots, macros, and other features. See the online Release Notes (Start > Programs > SmarTerm >
Release Notes ) for more information.
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Changing the Marketing profile
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So far, the Marketing profile contains the same features as your Admin profile. Profile users won’t see the
Administrator Toolbox under the Tools menu unless they have installed the Administrator Toolbox on
their PCs, which is not recommended for anyone but an administrator.

This section uses an example of opening an e-mail session, saving it as a session in the Marketing profile,
and modifying the session and profile with SmarTerm tools. You can use any available host session for
your own work and modify profiles however you wish.

Adding a session to a profile

In the following example, you will add a session to the Marketing profile created that you created earlier.

. Make sure the Marketing profile is loaded. (If it isn’t, select Tools > Administrator Tools > Load Profile
from Server.)

. Select File > New to create an e-mail session (or another type of session) on an available host. Keep in
mind the emulation types and communication methods that different departments might support.

. Select File > Save As to save the session. This example uses Mail for the session name. After you save
the Marketing profile, its users will be able to access this session, providing they have login rights to that
host and access rights to that folder. The session name appears in brackets in the title bar, to the right of
the profile name:

2F SmarTerm - Marketing - [Mail)
EM Fle Edt View Tool: Propeties Connection Window Help

Adding SmarTerm Buttons

You can add SmarTerm Buttons to the session to automate e-mail commands. You can create the button
text/tooltip and the DIL (dynamic information line) description. A palette can have as many as 128
buttons.

In the following example, you’ll add a SmarTerm Button to the Marketing profile’s e-mail session:
. Select Tools > SmarTerm Buttons.

. In the SmarTerm Buttons dialog, select the Vms_mail palette and click Open. The VMS palette appears.
You can dock it by dragging it to the main toolbar.

. Select File > Save to save the session with the SmarTerm Buttons.

. Select Tools > Administrator Toolbox > Save Profile to Server to save the profile changes.

Customizing a SmarTerm Button

The following example shows how to customize a SmarTerm Button and save it to the Marketing profile:
. In the mail session of the Marketing profile, select Tools > SmarTerm Buttons.
. In the SmarTerm Buttons dialog, select the Vms_mail palette and click Create/Edit.

. Customize the Send button: in the SmarTerm Buttons Editor dialog, click the Send button from the
Buttons list. Click Background Color from the Button definition group, select a shade of yellow in the
Color dialog, and click OK. In the SmarTerm Buttons Editor dialog, click Save.

. Select File > Save Session, then select Tools > Administrator Toolbox > Save Profile to Server.
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The Marketing profile now has a customized SmarTerm button. Later in this chapter, this example will
help illustrate how to merge profiles.

Changing the user interface (Ul)

You can enable or disable menu items, editors, and dialog tabs for a profile. When you change the UI for
a profile, the changes are stored in a Ul file that exists in the profile’s UI configuration folder. Users of
that profile will see the Ul the way you have defined it.

The following example lets you modify the Marketing profile’s user interface (UI) by removing two menu
items.

Let’s say that you want to make the Macros item in the Tools menu unavailable to Marketing profile
users. You’ll also remove the Macro Language Reference item from the Help menu.

To change the UI for the Marketing profile:
1. Make sure the Marketing profile is loaded. (If it isn’t, select Tools > Administrator Tools > Load Profile
from Server.)

2. Select Tools > Administrator Toolbox > Customize User Interface. In the Custom User Interface dialog,
all commands and categories are selected by default for a new profile.

3. Disable the Macros command on the Tools menu. Under Categories, click Tools to display its
Commands. Under Commands, click Macros to clear its check box. (A clear check box means that the
feature will not appear on the UI for this profile.)

4. Disable the Macro Language Reference from the Help menu. Under Categories, click Help. Under
Commands, click Macro Language Reference to clear its check box.

5. In the “Disabled commands are” group, select whether you want disabled commands to be grayed out or
removed entirely from the UL In this example, we don’t want the disabled items to appear at all on the
Tools and Help menus, so select Removed.

6. Click OK after you have finished configuring the UL

7. Select Tools > Administrator Toolbox > Save Profile to Server to save the changes to the Marketing
profile.

To see the Ul changes, you must exit and restart SmarTerm, and the profile whose Ul you changed must
be loaded.

Limiting sessions

You can limit how many sessions a user can open and how many connections a user has at one time to
one host. In the following example, we’ll limit the Marketing profile users to only one session at a time
and let them have only one connection to a host.

To limit sessions for the Marketing profile:

1. Make sure the Marketing profile is loaded. (If it isn’t, select Tools > Administrator Tools > Load Profile
from Server.)

2. Select Properties > Global Options and click the Session Limits tab.
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Global Dptions
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Settings for any global options tab apply to the profile you’re changing, with the exception of File
Locations, which you can’t specify for a profile.

3. Check Limit number of concurrent host sessions and specify 1 in the Allow only box.
4. Check Allow only one connection to each host, and click OK.

5. Select Tools > Administrator Toolbox > Save Profile to Server.

Creating the Accounting profile

While you have the Marketing profile loaded, you decide to create another profile based on it. This
profile will be for the Accounting department.

To create another profile:

1. Select Tools > Administrator Toolbox > Save Profile to Server As.

2. In the Save Profile to Server dialog, keep the same path as for Marketing. In the Profile name box, type
Accounting and click OK.

The new profile is created and is active. You’ll change it in the next section.

You can load a profile and modify it at any time. Just be sure to notify your users to update their profiles.

Restoring profiles and profile features

You can restore all profile defaults, or only selected ones, through the Tools > Restore from Profile
command. This section contains examples of how to do both types of profile restores.

An administrator (with the Administrator Toolbox installed) can restore any values from any profile
available on the current profile server. (The profile server is specified in the Profiles tab under Properties
> Global Options.) When a user selects Tools > Restore, values are restored only from the active profile,
which is shown under Properties > Global Options > Profiles.

Restoring profiles

In the last example, you created an Accounting profile that used the values of the Marketing profile—
which doesn’t have menu access to Tools > Macros or Help > Macro Language Reference. You decide to
restore menu access to these items from the factory profile to the Accounting profile:
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1. Make sure the Accounting profile is loaded. (If it isn’t, select Tools > Administrator Tools > Load Profile
from Server.)

2. Select Tools > Restore from Profile. The Restore from Profile dialog appears. The name of the profile
providing restore values is displayed in the dialog title bar.

3. From the Profile list, select the Factory profile. This is the profile from which you’re restoring values. In
this example, you’re replacing the Accounting profile user interface settings with those of the factory
profile.

Note:

Don’t check Delete local profile files prior to restore. Selecting this check box would result in deleting
all feature files from the Accounting profile. The most typical use of this option is to clear all values from
a current profile and replace them with values from a profile that allows extremely limited choices to
users.

4. This example is a partial restore, so you’re selecting only certain features. Under Categories, click Clear
All, then check User Interface Settings.

If you were restoring all values from the factory profile to a profile, you would select all Categories.
5. Click OK. SmarTerm asks you to confirm the restore.
6. Click Yes.

After profile values are restored, exit and restart SmarTerm for the changes to take effect.

Adding features to a profile

You can use Tools > Restore from Profile not only to restore settings from the factory profile, but also to
import features from other profiles. For example, imagine that another system administrator had a profile
with a customized SmarTerm Buttons palette that you wanted for a user profile. Assuming you had access
rights, you could select the other administrator’s profile server by using Properties > Global Options >
Profiles tab. Then you could load the profile and save it as a new profile to your own profile server.
Finally, you could merge the profile’s palette values into any other profile on the same server.

Undoing a profile restore

What if you merged profiles or restored a profile, only to realize that you want to set the profile back to
the way it was before you last restored it? Using the Tools > Undo Restore command sets a profile’s
SmarTerm configuration back to the state it was in before the latest restore.

Note:
The Undo Restore command is available only after the Tools > Restore from Profile command has been
used.

The profile restore in the preceding section restored menu item access from the factory profile to the
Accounting profile. Let’s say you decide, after all, to disable the Macro and Macro Language Reference
menu items for the Accounting profile. Because access was granted in the last restore, you can use Undo
Restore to undo that action.

To undo the last profile restore for the Accounting profile:

1. Make sure that the Accounting profile is loaded. (If it isn’t, select Tools > Administrator Tools > Load
Profile from Server.)

2. Select Tools > Undo Restore.
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SmarTerm advises that you are about to undo your current settings and asks if you want to continue.

3. Click Yes to undo the profile restore.

In this example, settings are retrieved from an Undo folder that’s created when you select Tools > Restore
from Profile. The Undo folder stores profile settings immediately before a restore.

The undo restore will not take effect until you exit and restart SmarTerm.

Restoring specific features

23

Administrators and end users can use the Restore button on feature dialogs to restore feature settings from
the active profile. For example, you can restore an edited SmarTerm Button to its active profile
appearance, directly from the SmarTerm Buttons dialog.

Note:
The Restore button only works if you have not saved your changes over the original file.

The following example will show how to restore SmarTerm Button palette values from the Accounting
profile. Let’s assume we’ve changed the color for the Send button from yellow to light blue in the mail
session for the Accounting profile (see “Customizing a SmarTerm Button” on page 19), but haven’t saved
this change to the profile.

. With the Accounting profile active and the mail session open, select Tools > SmarTerm Buttons.

. In the SmarTerm Buttons dialog, click Restore.

In the Restore from profile dialog, the feature category—in this case, SmarTerm Buttons—is already
selected. (Non-administrative users will not see the Profile list box and Delete local profile files prior to
restore check box.)
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3. Select the files that you want to restore from the profile. You can leave all SmarTerm Buttons selected or
you can click Clear All under Files and check only the Vms mail file. Then click OK.

4. SmarTerm asks you to confirm the local profile restore. Click Yes to continue.
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The yellow Send button is restored from the Accounting profile.

You must exit and restart SmarTerm for the changes to take effect.

Merging profiles

You can use the Restore from Profile command to merge features from multiple profiles into a new or
existing profile. The following example will create a new profile for the Sales department, merging
feature settings from the Admin, Accounting, and Marketing profiles. First, we’ll create the Sales profile.

1. Select Tools > Administrator Toolbox > Load Profile from Server, select the Admin profile, and click
OK.

2. SmarTerm tells you that it will restore all tools and sessions from the selected profile. Click OK to
continue.

3. Select Tools > Administrator Toolbox > Save Profile to Server As.

4. In the Save Profile to Server dialog, keep the same profile server path, but type a new profile name of
Sales. Then click OK.

The new Sales profile is active. It has all of the settings of the Admin profile. For this example, we’ll
borrow the user interface settings from the Marketing profile and the SmarTerm Buttons settings from the
Accounting profile and restore them to the Sales profile.

To restore Marketing and Accounting profile features to the Sales profile:

1. Select Tools > Restore from Profile. The Restore from profile dialog appears.
2. From the Profile list, select the Marketing profile.

When you select feature files from a profile to restore to the active profile, the selected files overwrite any
with the same name in the active profile. If the profile from which you’re restoring has a unique file, such
as a new SmarTerm Buttons palette, that feature is copied to the active profile.

Note:
When you merge profiles, don’t check Delete local profile files prior to restore. This option will delete all
local profile feature files.

3. Under Categories, click Clear All, then check User Interface Settings. Under Files, check stoffice.ui. This
restores the Marketing user interface (UI) features to the Sales profile, disabling the Tools > Macros and
Help > Macro Language Reference menu items.

4. Click OK. The UI settings from the Marketing profile overwrite the UI settings in the Sales profile.
5. Now select the Accounting profile from the Profile list.

6. Under Categories, click Clear All, then check SmarTerm Buttons. For Files, you can leave all files
selected, or you can click Clear All and select only the Vms_mail palette. This will restore the blue color
of the Send button to the Sales profile’s SmarTerm Buttons Vms_mail palette.

7. Click OK to restore the Accounting profile settings to the Sales profile.

8. Select Tools > Administrator Toolbox > Save Profile to Server to save the Sales profile.

Deleting a profile

You can delete any profile except the factory default. For the following example, we’ll delete the
Accounting profile.
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1. Select Tools > Administrator Toolbox > Delete Profile from Server.
2. In the Profile name box, type Accounting or select it from the list, and click OK.

The profile is deleted immediately.

Note:
If the profile you want to delete isn’t on the list, you must first change the profile path by selecting
Properties > Global Options > Profiles tab.

If you happen to delete the loaded profile, the profile space in the title bar goes blank. You can load
another profile at this point. If you don’t, SmarTerm prompts you to do so the next time you select Tools
> Restore from Profile.

3. Click OK. Then exit and restart SmarTerm.

Reloading your administrator profile

After you work on user profiles and want to resume any work in SmarTerm for yourself, make sure your
own administrator profile is active by selecting Tools > Administrator Toolbox > Load Profile from
Server.
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Profile Management Reference

This chapter provides a task-oriented reference for profile management. To learn about profile
management features in the context of examples, please see “Profile Management Workbook™ on page 14.
Then use this chapter as a quick reference when you create and manage user profiles.

Creating a profile server

You can create a profile server when you:
* Save a new profile.

+ Save an existing profile as a new profile.

To create a profile server:

1. Create a new profile and save it by selecting Tools > Administrator Toolbox > Save Profile to Server. Or
save an existing profile as a new profile by selecting Tools > Administrator Toolbox > Save Profile to
Server As.

The Save Profile to Server dialog appears.

2. In the Save Profile to Server dialog, specify a new profile server path in the Profile server path box. You
can type a pathname or click Browse to specify another path.

3. In the Profile name box, type a name for the new profile. You must type a profile name when you create

a new profile server.

4. If a profile server doesn’t exist on the specified path, SmarTerm asks whether you want to create a new
profile server at this location. Click Yes to create the new profile server.

The profile loads after you create it, and its name appears in the SmarTerm title bar. If a session is open,
the session name appears enclosed within brackets.

Note:
To specify the current profile server, use the Profiles tab under Properties > Global Options.

Selecting a profile server

If you have multiple profile servers, use the Global Options Profiles tab to select a different profile server.
1. Select Properties > Global Options and click the Profiles tab.
2. In the Profile server path box, type or browse for a path to another profile server.

3. From the Profile name list, select the profile you want to use, and click OK.

Loading a profile
1. Select Tools > Administrator Tools > Load Profile from Server.

2. In the Load Profile from Server dialog, type or select a profile name, and click OK.
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3. SmarTerm warns you that the current tools and features will be replaced by those in the selected profile.
Click Yes to continue.

You must exit and restart SmarTerm for the changes to take effect.

Creating a new profile

You can create a profile for yourself, then use it as a model for creating other profiles for user groups.

1. Open SmarTerm. SmarTerm loads the current profile specified in the Global Options Profiles tab.

Note:
If you’re not using the factory profile and want to create a new profile based on factory defaults, select
Tools > Administrator Toolbox > New Profile.

2. Use SmarTerm’s tools and features to change the settings to the way you want them. The factory profile
has all SmarTerm features available.

3. Select Tools > Administrator Toolbox > Save Profile to Server As.

The profile is saved to the profile server shown in the Profile server path box. To save the profile to
another profile server, type a new profile server path name or click Browse and select a path. If a profile
server doesn't exist on that path, SmarTerm asks if you want to create a new profile server.

4. In the Profile name box, type a name for the profile, and click OK.

Saving a profile
You can save a new profile based on the factory default profile, or save changes to the current profile.
1. Select Tools > Administrator Toolbox > Save Profile to Server.

2. In the Profile server path box, keep the current path, type a new path to create a new profile server, or
browse for a profile server.

The Profile server path points to the folder where the profile is stored.

3. In the Profile name box, type a name for the new profile, and click OK.

Saving an existing profile as a new profile

1. Load the existing profile.
2. Select Tools > Administrator Toolbox > Save Profile to Server As.

3. The profile is saved to the profile server shown in the Profile server path box. To save the profile to
another profile server, type a new profile server path name or click Browse and select a path. If a profile
server doesn't exist on that path, SmarTerm asks if you want to create a new profile server.

4. In the Profile name box, type a name for the new profile, and click OK.

Deleting a profile

1. Select Tools > Administrator Toolbox > Delete Profile from Server.

2. In the Profile name box, type the name of the profile you want to delete, or select a profile name from the
list, and click OK.
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Note:
If the profile you want to delete isn't on the list, change the profile server path by selecting Properties >
Global Options > Profiles tab.

Modifying an existing profile
1. If the profile you want to change isn’t on-screen, load the profile. Select Tools > Administrator Toolbox
> Load Profile from Server, specify a profile name in the Load Profile from Server dialog, and click OK.
Then exit and restart SmarTerm to activate the profile you loaded. The current profile name appears in the
SmarTerm title bar.

If the profile you want to change doesn't appear in the Profile name list, select Properties > Global
Options and click the Profiles tab. Change the path to the profile server that contains the profile you
want to modify.

2. Change the profile’s session properties, Ul or features.

3. Select Tools > Administrator Toolbox > Save Profile to Server to save your changes. (To save the
changes as a new profile, select Tools > Administrator Toolbox > Save Profile to Server As.)

Configuring the user interface for a profile

You can change the appearance of the SmarTerm user interface (UI) for a profile that you have created.
You can enable or disable menu items, editors, and dialog tabs. Users of this profile will see the
SmarTerm UI according to how you configure it for the profile.

To configure the SmarTerm Ul for the current profile:

1. Select Tools > Administrator Toolbox > Customize User Interface.

2. In the Customize User Interface dialog, clear (disable) or check (enable) the categories or commands,
according to how you want sessions in this profile to appear to users. Commands in the right-hand
column appear for the selected category.

To do this: Click this:

Disable all categories and commands Clear All under Categories

Enable all categories and commands Select All under Categories
Disable all commands within one category Clear All under Commands
Enable all commands within one Select All under Commands
category

Disable individual commands within one category Clear the check box next to the command

Enable individual commands within one category = Check the check box next to the command

3. In the Disabled commands are group, select whether you want disabled commands to appear as grayed
out on the Ul or to remove them entirely from the UL

4. Click OK after you have finished configuring the UL

To see the UI changes, you must exit and restart SmarTerm, and the profile whose Ul you changed must
be loaded.
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Restoring a profile

The Restore from Profile feature lets you restore features to the current profile. For example, a restore lets
you change a profile and then restore it to the last saved version that resides on your profile server. You
can also use the restore feature to import settings from another profile.

To restore a profile:

1. Select Tools > Restore from Profile.

2. In the Restore from Profile dialog, select the features you want to restore to the current profile. For
example, if you disabled a menu item for a profile and want to restore that menu item, click Clear All for
Categories, and select User Interface.

3. Under Profile, select the profile from which you want to restore features.

Note:
The ability to see and use this feature is available only to Administrator Toolbox users.

4. To delete all SmarTerm feature settings except the ones you select to restore from a profile, check the
Delete local files prior to restore check box.

Note:
The ability to see and use this feature is available only to Administrator Toolbox users.

When you select this check box and proceed with a restore, the current profile will contain only those
features that you selected to restore from the profile specified in the Profile list.

5. Click OK after you have selected the settings you want to restore.

The restore will not take effect until you exit and restart SmarTerm.

Undoing a profile restore

Undoing a profile restore sets the SmarTerm configuration back to the state it was in before the latest
restore.

Note:
The Undo Restore command is available only after the Restore from Profile command has been used.

1. Select Tools > Undo Restore.
SmarTerm advises that you are about to undo your current settings and asks if you want to continue.
2. Click Yes to undo the last profile restore.

The undo restore will not take effect until you exit and restart SmarTerm.

Merging profiles
Use the Restore from Profile command to merge features from multiple profiles into an existing profile.

1. Load an existing profile (Tools > Administrator Tools > Load Profile from Server) or save an existing
profile as a new profile (Tools > Administrator Tools > Save Profile to Server As).

2. Select Tools > Restore from Profile.

3. From the Profile list, select the profile from which you want to restore sessions or tools to the current
profile.
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Note:
Don’t check the Delete local profile files prior to restore check box when you merge profiles. This option
will delete all features from the current profile.

. Check any or all tools and sessions to restore from the Category and Files list. For example, to copy
sessions from a selected profile to the current profile, put a check in the Sessions check box. To copy all
sessions from one profile to another, click Select All. To copy only selected sessions, check individual
sessions listed under Files. If any features are named the same in both profiles, the features from the
profile you’re restoring from overwrite those features in the current profile.

. Click OK after you select tools and sessions to merge into the current profile.

You can continue to select other profiles and restore tools and sessions from them to the current profile.

Setting session limits

Use the Global Options > Session Limits tab to:
+ Limit the number of sessions to a host that can be opened at the same time

+ Allow only one connection to a host

To set session limits:

. Select Properties > Global Options and click the Session Limits tab.

. To limit the number of sessions to a host that can be opened at the same time, check Limit number of
concurrent host sessions and specify a number in the Allow only box.

. To limit this session to only one connection per host, check Allow only one connection to each host.

. Click OK.
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This chapter describes SmarTerm’s session type support and its features, which you use to create and
modify sessions and profiles.

Session types

Depending on which SmarTerm license you purchased, SmarTerm 3270/5250, SmarTerm Essential, or
SmarTerm Office) you will have some or all of the session types listed below.

IBM 3270 Display emulates IBM 3278 and 3279 form-based terminals, along with enhanced terminal
attributes. Use it to connect to hosts running the TNSNA protocol or Telnet.

IBM 3270 Printer emulates the IBM 3287 printer.

IBM 5250 Display emulates IBM 3477-FC, 3477-FG, 3180-2, 3179-2, 3196-A1, 5292-2, 5291-1, or
5251-11 terminals.

IBM 5250 Printer emulates the IBM 3812 printer.

Digital VT emulates Digital Equipment Corporation (Digital) VT series terminals from the basic VT52
text terminal through the sophisticated VT420 text terminal. Use it to connect with Digital VMS, All-
in-----1, and Unix hosts such as the Data General AViiON. SmarTerm also includes the ISO Latin-1,
ISO Latin-2, and ISO Latin-9 (with Euro symbol support) character sets, and support for host control
sequences.

Digital VT Graphics emulates all of the above listed text terminals, plus the following graphics
terminals: VT240 (monochrome graphics), VT241 (four-color graphics), VT340 (16-color ReGIS and
sixel graphics), and Tektronix 4010/4014 graphics terminals.

ANSI emulates ANSI terminal mode. Use it to connect to hosts that run a bulletin board service (BBS)
that supports standard ANSI escape sequences. Additional support includes sequences that add color,
lines, and cursor positioning to your screen emulation.

SCO ANSI console emulation is a variant of ANSI-BBS and DEC VT emulation modes. Use it to
connect to SCO XENIX and SCO UNIX hosts. The emulation combines the features and sequences
listed in the SCO screen (HW) manual, some VT510 ANSI mode features, and some Persoft extensions.

Data General Dasher emulates Data General Dasher text and graphics terminal, from the high end
D470C graphics terminal to the D200 text terminal. Use it to connect to MV hosts and hosts running
CEO Workstation.

WYSE 50/60 emulates text terminals in WYSE 50 or WY SE 60 mode.

For more information about session types, see the online help system available through the Help menu.

Features for all session types

SmarTerm has many features to make emulation and network connectivity easy, reliable, and
customizable. This section provides descriptions of those features. For more information about SmarTerm
features, see the online help system.
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Connection types

To make a connection type to a host, you can choose from the following connection types that SmarTerm
supports:

* Telnet

* Direct serial

* Modem

* Microsoft Host Integration Server (formerly called Microsoft SNA Server)
» SSH

Not all connection types are available for all session types.

File transfer types

You can use SmarTerm to send and receive files between your PC and a host or other computer.
SmarTerm can transfer both text and binary files using the following transfer protocols:

* Secure FTP (SFTP)

+ INDSFILE

« KERMIT

+ SCP

« XMODEM

* YMODEM

« ZMODEM

In addition you can use SmarTerm to:

* Paste text from a file on your PC to the host.
* Copy text from the host to a file on your PC.
* View files on the host or your PC before transferring them.

Not all file transfer types are available for all session types. SCP, for instance, only works with hosts that
support it.

MDI Workbook View

The MDI Workbook View presents multiple SmarTerm sessions as tabbed worksheets. This lets you move
easily between open sessions by clicking on the tab. Use Window menu commands to arrange the
sessions within the SmarTerm window.

Each open session has a window with a tab that shows the name of the session. A host icon on the tab
blinks when a session has incoming data.

Dialog View
Dialog View makes an IBM terminal screen look and act more like the GUI (graphical user interface)

environment of Windows. With Dialog View enabled, the screen has a three-dimensional look. Dialog
View makes moving around the screen more intuitive for Windows application users.
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Dialog View is an optional feature. When you enable Dialog View, the HotSpots feature is enabled
automatically as well.

HotSpots

SmarTerm’s HotSpots feature lets you create clickable areas on the screen to help use an existing host
application. These clickable areas, called HotSpots, work the way buttons do in a Windows application.

All session types except ANSI support HotSpots.

When you click on a HotSpot with the mouse, the HotSpot can:
* Send a string to the host.

* Run a macro.

* Load another HotSpots file.

* Load SmarTerm Buttons.

e Unload SmarTerm Buttons.

Triggers

Depending on what screen you’re on in your host application, you might want different SmarTerm tools
available to you. Certain SmarTerm Buttons, HotSpots, keyboard maps, and color schemes might apply to
only certain host screens. Triggers allow you to load these tools automatically when you want them to
appear.

A Trigger file contains a collection of Triggers. Each Trigger specifies a string that causes it to fire. When
the Trigger fires (when the host screen appears), SmarTerm loads the tools you want, or unloads tools you
no longer want loaded. To put it all in place, you load the Trigger file when you open a SmarTerm
session.

Using Triggers, you can have greater control over how your users navigate host applications. Triggers can
simplify application navigation for novice users by making the most of the SmarTerm tools available.

Macro language recorder

SmarTerm provides a macro recorder to let you record your actions as a macro while using SmarTerm.
Recorded macros can be run whenever you like and can be associated with a SmarTerm Button for easy
access. The macro recorder is useful for recording simple login operations, routine file transfers, and other
host operations.

SmarTerm’s macro recorder doesn’t record every single action within SmarTerm. Instead, as you perform
tasks within SmarTerm, the macro recorder analyzes those tasks, and records those that have associated
macro language commands. It also looks for incoming prompts and stores outgoing keystrokes.

For more information about the macro recorder, see the online help system and the SmarTerm Macro
Guide. This guide also contains detailed information about macro conventions and macro commands.

SmarTerm Buttons

SmarTerm Buttons are custom buttons that allow you, with a single click, to perform familiar functions:
* Run macros.
+ Stop a running macro.

¢ Send text to the host.
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¢ Load a different set of buttons.

SmarTerm Buttons provide functions within a particular session. Access to a set of SmarTerm Buttons can
be limited to you, or broadened to your workgroup.

You control the button format. You can:

* Choose a picture from SmarTerm’s list (for profiles), or use your own .BMP, .DLL, .EXE, or .ICO file
(for customized sessions).

 Create the button text/tooltip and the DIL (dynamic information line) text.

» Determine how the picture and/or text appears in the button, including text, background colors, and
font style, weight, and size.

* Dock the buttons anywhere or allow them to float on the session window.

Language support

SmarTerm can operate in four languages: English, French, German, and Spanish. The language you chose
for Setup is the default language for the first time you run SmarTerm. You can change the language for
any session with the Language command on the Properties menu. Each session can use a different
language, and you can change to another language whenever you care to without disconnecting from the
host or exiting SmarTerm.

All aspects of SmarTerm operate in the language of the current session, including the menus, the dialogs,
and the online help system. However, all information about the SmarTerm Macro Language is available
only in English.

SmartMouse

SmartMouse enables mouse support to host applications by letting you define mouse actions—mouse
events that trigger specific actions such as:

* Move the cursor around the screen.

» Invoke commands presented in a host application menu.
* Send the selected word to the host.

* Send the selected word and a carriage return.

» Execute macros.

For example, you can set up SmartMouse to allow you to left-click to move the cursor to a selected spot
on the screen.

Terminal keyboards and keyboard mapping
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Terminal keyboards let you display how a key is mapped and click on a key to send information to the
host. Keyboard mapping lets you customize your default keyboard to send a word, macro, or a command
to the host by pressing your keyboard key. Default keyboard maps are loaded for each session type, and
you can customize these maps and save them as new maps using the Keyboard Map Editor.

For example, depending on the host application, you may want a different keyboard map to be in effect.
This is because one set of keystrokes might work best for most host operations, but a specific host
application might require a completely different mapping. In this case, you can use the Keyboard Map
Editor to customize a map for use with that host application, and use another map for your regular
connection to that host.
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OLE and DDE

Object Linking and Embedding (OLE) and Dynamic Data Exchange (DDE) let applications share data. In
other words, one Windows application can automatically send and receive data from other Windows

application(s) that support OLE or DDE.

SmarTerm’s OLE support allows you to link applications and data from many sources at the same time. It
is a full-featured OLE, allowing complete integration with OLE-compliant applications. For example, you
can connect via SmarTerm to a host application and display a table of information, then link that table to
a Microsoft Excel spreadsheet.

DDE Client and Server support allows SmarTerm to receive data and immediately send that data to
another Windows application, such as a spreadsheet or word processor, without having to update it
manually. Sites can integrate SmarTerm into an Executive Information System using its DDE capabilities.
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